dimanche 14 avril 2013 à

Plymouth cassé sur Ubuntu 13.04 Raring Ringtail

Après avoir installé un pilote prioritaire nVidia je me suis retrouvé avec le chargeur graphique plutôt..... bref pas beau quoi. Pour retrouver un jolie logo j'ai utilisé une méthode qui se trouve dans la doc Ubuntu-fr qui a fonctionné sur la 13.04. Donc si vous aussi avez des problèmes avec la gueule de plymouth et la résolution de grub voici comment faire:
Pour commencer vous devez connaître la résolution de votre écran pour cela lorsque grub se lance tapez C puis vbeinfo et notez la résolution la plus haute ( pour moi 1024x768 ).
Ensuite j'ai du installer le paquet v86d avec la commande :

sudo apt-get install v86d

Maintenant éditez GRUB :

sudo gedit /etc/default/grub

Puis remplacez la ligne :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

par :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1024x768-24,mtrr=3,scroll=ywrap"

( ATTENTION: Modifiez bien la résolution )


Pour la résolution modifiez cette ligne en retirant le # puis remplacez la résolution :

#GRUB_GFXMODE=640x480

Enfin ajouté juste en dessous cette ligne :

GRUB_GFXPAYLOAD_LINUX=1024x768

Enregistrez et fermez ce fichier et puis :

sudo gedit /etc/initramfs-tools/modules

Collez a la fin du fichier la ligne suivante :

uvesafb mode_option=1024x768-24 mtrr=3 scroll=ywrap

Enregistrez et fermez.
Avant de redémmarer générez à nouveau Grub et initramfs :

sudo update-grub
sudo update-initramfs -u

Après un redémarrage, l'affichage devrait se faire en haute résolution et propre. Si vous avez le logo nVidia qui se charge aussi au démarrage vous pouvez le supprimer avec la commande :

sudo nvidia-xconfig --no-logo

A vous de jouer !

dimanche 21 octobre 2012 à

Le lanceur Unity apparaît plus après le passage de la souris

Premier problème avec la nouvelle version d'ubuntu. Je viens de voir que lorsque je passe la souris vers le lanceur rien ne se passe ( grrr ) je vais donc dans mes réglages d'unity qui sont sur masquage automatique du lanceur bref comme toujours je test sur jamais cela marche correctement mais j'aime pas avoir le lanceur toujours sur mon écran donc je reboot fait une petite maj de nVidia qui était disponible mais cela change rien donc après quelques tests j'ai changé le pilote nvidia-current-updates par le nvidia-current puis un reboot et voilà la solution fonctionne correctement. Si vous avez aussi le même problème allez donc dans sources de logiciels et Pilotes Additionnels pour faire les mofifications.