Passer Dotclear en https chez OVH

dotclear-logo.jpg Passage de mon Dotclear en https ( c'est les vacances donc pas grand chose a faire ). Plus ça va, plus les sites passent en https alors de là je me suis lancé aussi dans la manip sur un hébergement mutualisé chez OVH que je vais vous expliquer. Mais avant tout si vous voulez savoir c'est quoi et pourquoi etc je vous invite a faire un tour sur Wikipedia pour les explications !

Maintenant que vous avez fait le tour des explications je vais indiquer la manip chez OVH !
Pour commencer nous allons vérifier si le domaine que vous voulez passer en https a bien le SSL d'activé en vous connectant dans votre Manager OVH puis un petit clic dans votre hébergement et de là Multisite .
Si tout se passe bien votre domaine est dans la liste avec le SSL en vert Actif sinon activez le SSL sur le domaine en question et cliquez sur Regénérer le certificat SSL.
Maintenant nous passons a Dotclear dans Mon tableau de bord et Paramètres du blog pour ajouter un s après le http dans l'URL du blog comme ceci :

https://www.votredomaine.fr/index.php?

Ensuite avec votre client FTP vous allez modifier le fichier config.php qui se trouve dans le dossier /inc/ a la racine de votre blog en ajoutant un s comme l'exemple en dessous:

// Admin URL. You need to set it for some features.
define('DC_ADMIN_URL','https://www.votredomaine.fr/admin/');

Et pour finir toujours avec votre client FTP vous allez ouvrir votre .htaccess qui se trouve a la racine de votre blog et ajouter les lignes suivante:

RewriteEngine on
RewriteCond %{SERVER_PORT} 80
RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

Vous sauvegardez le tout et normalement cela devrait être fonctionnel mais après il peut toujours avoir certains cas ou cela pose des conflits comme pour moi avec Piwik qui lui était appelé en http ce qui donnait une alerte avec les navigateurs qui est :

cette page tente de charger des scripts à partir de sources non authentifiées

Mais une fois résolu, plus de problèmes et tout fonctionne.

Bonne intox avec vos fichiers xD

Commentaires

1. Le dimanche 1 janvier 2017 à, 22:28 par Laurent

Bonsoir,

Piwik ne fonctionne plus chez moi depuis le passage en https. Une petite idée j'ai une erreur lorsque j'essaye de changer le lien dans l'application..
Merci

2. Le mardi 3 janvier 2017 à, 17:52 par Cris

Salut laurent, moi aussi ça fonctionne plus j'ai posté mon problème sur le forum de dotclear mais pas encore de réponses : https://forum.dotclear.org/viewtopi...

3. Le mercredi 29 mars 2017 à, 17:36 par Marc

Merci pour le tuto, bien pratique. En revanche chez moi tout fonctionne bien sauf les liens vers les billets mais je pense que c'est en raison que mes urls ne contiennent pas le index.php?, dans mon .htaccess de base j'avais cette ligne pour le virer $ index.php?$1



Est-ce que tu as une idée sur l'endroit ou le mettre pour conserver ce mode d'écriture ?

4. Le jeudi 30 mars 2017 à, 18:05 par Cris

Bonsoir Marc,

Je pourrais regarder ce weekend si tu as pas trouvé la solution avant :)

5. Le jeudi 30 mars 2017 à, 21:23 par Marc

Merci mais finalement je viens de comprendre ce qui merdait. Merci du tuto !

Ajouter un commentaire

Les commentaires peuvent être formatés en utilisant une syntaxe wiki simplifiée.

Fil des commentaires de ce billet