Plymouth cassé sur Ubuntu 13.04 Raring Ringtail

Après avoir installé un pilote prioritaire nVidia je me suis retrouvé avec le chargeur graphique plutôt..... bref pas beau quoi. Pour retrouver un jolie logo j'ai utilisé une méthode qui se trouve dans la doc Ubuntu-fr qui a fonctionné sur la 13.04. Donc si vous aussi avez des problèmes avec la gueule de plymouth et la résolution de grub voici comment faire:
Pour commencer vous devez connaître la résolution de votre écran pour cela lorsque grub se lance tapez C puis vbeinfo et notez la résolution la plus haute ( pour moi 1024x768 ).
Ensuite j'ai du installer le paquet v86d avec la commande :

sudo apt-get install v86d

Maintenant éditez GRUB :

sudo gedit /etc/default/grub

Puis remplacez la ligne :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

par :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1024x768-24,mtrr=3,scroll=ywrap"

( ATTENTION: Modifiez bien la résolution )


Pour la résolution modifiez cette ligne en retirant le # puis remplacez la résolution :

#GRUB_GFXMODE=640x480

Enfin ajouté juste en dessous cette ligne :

GRUB_GFXPAYLOAD_LINUX=1024x768

Enregistrez et fermez ce fichier et puis :

sudo gedit /etc/initramfs-tools/modules

Collez a la fin du fichier la ligne suivante :

uvesafb mode_option=1024x768-24 mtrr=3 scroll=ywrap

Enregistrez et fermez.
Avant de redémmarer générez à nouveau Grub et initramfs :

sudo update-grub
sudo update-initramfs -u

Après un redémarrage, l'affichage devrait se faire en haute résolution et propre. Si vous avez le logo nVidia qui se charge aussi au démarrage vous pouvez le supprimer avec la commande :

sudo nvidia-xconfig --no-logo

A vous de jouer !

Commentaires

1. Le mardi 16 avril 2013 à, 20:53 par Moi

Nickel pour moi aussi, faudrait l'annoncer sur la doc que la solution fonctionne aussi sur cette monture d'ubuntu sinon :up: parfait pour moi.

2. Le mercredi 17 avril 2013 à, 18:50 par kipof

Je vais attendre le 25 pour voir si d'autres majs pourraient résoudre le problème mais bon chez moi j'ai toujours eu des problèmes avec plymouth :D

3. Le mercredi 17 avril 2013 à, 19:25 par Moi

Ouai, vos mieux attendre car c'est pas encore au top chez moi mais bon merci déjà pour plymouth même si je pense refaire une installe propre après le 25 :)

Ajouter un commentaire

Les commentaires peuvent être formatés en utilisant une syntaxe wiki simplifiée.

Fil des commentaires de ce billet